No item crawled after doing index reset

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

No item crawled after doing index reset

Manu
Hello Anil,

I hope you are doing great!

I have configured search in SP 2013 environment and crawled successfully. I have scheduled full crawl during weekend, Full crawl keep on running from 100 hrs with errors in crawl log

1.Processing this item failed because of a timeout when parsing its contents
2.The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.
3.The SharePoint item being crawled returned an error when attempting to download the item

I did index reset and started full crawl(we have one crawler). No item crawled and got error "The SharePoint item being crawled returned an error when attempting to download the item"


Can you suggest me, how can I resolve this issue.
Reply | Threaded
Open this post in threaded view
|

Re: No item crawled after doing index reset

Anil Avula
Administrator
HI Manu,It seems you have multiple issues happening in the search.Thanks for your visit on the blog.Find my answers below and do feel free to contact me if any issues with share-point.

1.Processing this item failed because of a timeout when parsing its contents
Check the link below

http://expertsharepoint.blogspot.de/2013/12/this-item-could-not-be-crawled-because.html


2.The crawler could not communicate with the server. Check that the server is available and that the firewall access is configured correctly. If the repository was temporarily unavailable, an incremental crawl will fix this error.

Try disable the firewall and restart the Search services in the server.

Check below Links:

http://expertsharepoint.blogspot.de/2014/07/the-search-service-is-not-able-to.html
http://expertsharepoint.blogspot.de/2014/06/this-item-could-not-be-crawled-because.html

3.The SharePoint item being crawled returned an error when attempting to download the item
Check the link below

http://expertsharepoint.blogspot.de/2014/09/crawl-fails-with-error-sharepoint-item.html

Anil Avula's SharePoint Blog[MCP,MCSE,MCSA,MCTS,MCITP,MCSM]
Reply | Threaded
Open this post in threaded view
|

Re: No item crawled after doing index reset

Manu
Thank you for your response Anil!!!

crawled successfully after reboot my Crawl server. In crawl log we found few errors.
Reply | Threaded
Open this post in threaded view
|

Re: No item crawled after doing index reset

Manoj Kumar
In reply to this post by Anil Avula
HI Anil,

We have increased the time out value from 60'60 to 300'300. still we are getting below error and we have performed index reset and did full crawl. Please suggest.

Processing this item failed because of a timeout when parsing its contents
Reply | Threaded
Open this post in threaded view
|

Re: No item crawled after doing index reset

Clippy
This is an old post but I'm posting this in case anyone else stumbles here while trying to fix the error "Processing this item failed because of a timeout when parsing its contents". This is what worked for me. Use \16.0\ for SP2016 or \15.0\ for SP2013.

$registryPath = "HKLM:\SOFTWARE\Microsoft\Office Server\16.0\Search\Ceres\DocParser"
if (!(Test-Path $registryPath))
{
        New-Item -Path $registryPath -Force | Out-Null
}
New-ItemProperty -Path $registryPath -Name ParsingTimeout -PropertyType DWord -Value 12000000 -Force | Out-Null
New-ItemProperty -Path $registryPath -Name MaxSandboxMemory -PropertyType DWord -Value 12000000 -Force | Out-Null
New-ItemProperty -Path $registryPath -Name MaxSandboxRequestWaitTime -PropertyType DWord -Value 8264 -Force | Out-Null